Understanding of Quiet Period


(Thomas Lohrum) #1

Hi,

in the docs there is the following quote:
“While in the quiet period, additional commits to the repository will not trigger new builds,
however these new changesets will be added to the build that is currently in the quiet period.”

I have a trigger on a Git repository. It is the only repository. The quiet period is set to 360 minutes. Associate Changesets is set to ‘All since last successful build’.

Changes:
Change 48
Change 47 *
Change 46
Change 45

Change 47 triggered a build. After committing Change 48 i observed, that the quite period was reset, thus proving the changeset was recognized. Then i clicked “end quiet period”, because i wanted the build immediately. The result was a build on Change 47, ignoring Change 48.

My expectation is, that Change 48 should have been included.

Any ideas?

Thomas


(Dave Sparks) #2

Hi Thomas,

We have not been able to reproduce this issue. In the code, the quiet period time is only reset after the new changeset is added to the build.

Is “Change 48” on the same branch as the other changes? Is it added to the changes list for the configuration and does it start a separate build?

To help us replicate your scenario, can you send details of your repository and trigger settings via direct message (or to support @ finalbuilder.com)?

Are you are able to reproduce this situation with debug logging enabled. If so, a copy of the debug log would help us figure out what is causing this.


(Thomas Lohrum) #3

Hi Dave,

the changesets are all on master. What might be relevant though, is Change 48 being a merge-commit.

Trigger-Settings:
The quiet period is set to 360 minutes.
Associate Changesets is set to ‘All since last successful build’.
Trigger On [Default Branch]
Comment Patterns Exclude [^(?!#00000).*$$]

Everything else is default.


(Dave Sparks) #4

Hi Thomas,

We still can’t reproduce this with a merge commit.

Is it possible that the comment of the merge commit starts with something other than “#00000” and is therefore skipped from the trigger. Note that only changesets which match all the trigger filters are added to a quiet period build. I can see how this might be unexpected - we are considering whether to add an option to change this behaviour.

Note that you didn’t answer these questions:

Is it added to the changes list for the configuration and does it start a separate build?

Can you also let us know which version of Continua CI you are running?

Incidentally, why not just put [^#00000] in the Comment Patterns Include rather than using a complex regular expression with a negative lookahead?


(Thomas Lohrum) #5

The comment for the merge-commits start with something like #12345.

As far as i remember: No.

Continua Version is the latest 1.9.0.374.

Because you’re a lot smarter than me :wink::sweat_smile:
Thanks for the hint. You’re correct.

Dave, thanks for your efforts. As for the time being i will further observe the issue. No further actions required.

Thomas


(Thomas Lohrum) #7

Because, the pattern [^#00000] must be put as an exclude. :slight_smile: