Suddenly getting "Action: xxxx is not loaded and is referenced by this project" errors


(Jonathan) #1

I had a process that was running fine until January 12th.  I just checked on it, and when I load the process I am getting errors that state:

"WARNING Action: "Delete File(s) is not loaded and is referenced by this project, if you save this project the missing actions will be deleted from the project
(to correct the issue, go to Tools -> Package Manager and ensure the relevant action package (.bpl) file is loaded and enabled.)"

I am getting this message related to many different actions.  “Send Email”, “MSSQL Execute SQL”, “Execute Program”, “Get File Size”, “File/Fileset Iterator”…

When I look at Tools -> Package Manager, it seems that all of the available packages are already installed.  I cannot find where to even begin to load the packages that I am missing.

I even downloaded and installed the latest Automise 5 update, figuring that the missing files/actions would get loaded, but that did not seem to help.

Help?


(Vincent Parrett) #2

Have a look at

C:\Users\YourUserName\AppData\Roaming\Automise5\Automise5.ini

Note the username should be the user the project normally runs under.

There is likely a [DisabledPackages] section. Delete that and see if the packages load. The other thing to look at is whether antivirus software is interfering with the loading of the packages.

Other than that, try uninstalling an re-installing.


(Jonathan) #3

There is no [DisabledPackages] section in the ini file. I uninstalled and reinstalled Automise 5, and got the exact same validation errors when opening the project after the reinstall.

I can check into the antivirus software (we run Kaspersky on all company machines), but what exactly am I looking for? Why would some packages get loaded and not others?


(Jonathan) #4

Actually, it looks like Sophos (not Kaspersky) is running on this particular machine.  Still not sure what to look for.


(Vincent Parrett) #5

It sound to me like some files are missing, is there an FBFile.bpl file in the Automise install folder? This is the file that has the Delete Files action.

The only time I have seen this before was when antivirus software removed files (false positive). I just tested this build with virustotal and it shows as clean : http://downloads.finalbuilder.com/downloads/automise/500/AT500_927.exe


(Jonathan) #6

There is an FBFile.bpl in the Program Files(x86)/Automise 5 folder, yes. It is 4,402 KB. Is that the right size for the latest build? Since that file exists, what do I do now? Do I need to try to get IT to configure Sophos somehow? I am really at a loss. I can try to install the clean build you mentioned, I suppose.


(Jonathan) #7

I installed the clean build you mentioned, and got the same error. Even when I uninstall Automise, and reinstall, I got this problem. Please help. Any ideas will be considered. I don’t know why this application suddenly started acting this way.


(Vincent Parrett) #8

Uninstall Automise 5, and then rename C:\ProgramData\VSoft\Automise5\Automise5.ini

Install Automise 5 again.

As to why this has happened, I have no idea. I have seen issues like this in the past, and every time bar none, antivirus software was the cause. That’s really out of our control.


(Vincent Parrett) #9

It’s also worth checking if there are any eventlog errors related to this issue. Also check antivirus system to see if it has quarantined any files.


(Jonathan) #10

I checked the event log, and did not find anything. I do not have permissions to check the antivirus, though I have submitted an inquiry about that with out IT department.

It seems that uninstalling, renaming the C:\ProgramData\VSoft\Automise5\Automise5.ini file and re-installing did the trick. I looked at that ini file, and there seemed to be the right packages listed, so I am not sure why that solved the problem, but it seems to have done so. Much appreciated!