SFTP Download Files Not Working, unless I am missing something (issue with Remote Path)

We are moving our DR server from one host to another, and rather than recreate the Automise project files on the new server, I want to download the files from the existing server and then move them to the new server via SFTP.

However, when I try to use SFTP Download Files, I cannot find a way to get the Remote Path to work with the File Mask value. I have tried putting a leading forward slash on the Remote Path, I have tried no slash at the start of the Remote Path, I have tried a trailing forward slash, I have tried a trailing backslash…in all cases, I get a “Could not download files: Invalid Path” error. The project I am using successfully UPLOADS files via the same SFTP connection to a different directory.

Before posting this item, I went to the Help page for the SFTP Download Files action to see what the format of the Remote Path was, and tried that, but that did not work either. That is the attempt in the attached screenshot.

Any ideas? Build is There is no way to upload projects to an online repository attached to my Automise account, is there? That would make it easier to move the projects around from one machine to another when needed.



I got this to work, by putting the files I want to download in a subdirectory of the directory where I am uploading to the same connection. There must be something special defined in terms of a home directory that I am missing.

I suspect the help is wrong. If you enter a relative path then I believe it is relative to the user’s home directory, otherwise you need to specify the full path. I will test this today and correct the help if required.

We have projects that the SFTP Download Files action (for offsite backups), but looking at them they all specify the full remote path, e.g

No, we are not a cloud service and tbh your’s is the first request of this nature - the costs to add such a feature would far outweigh the benefits unfortunately.

That’s fair. I was not asking you to implement a cloud service…just wondering if something existed that I missed :slight_smile: