Set Build Delphi Library Path


I’m using Final Builder 8 to compile some Delphi Projects, but it seems that the Library Path is not taken into account: compilation fail with “unit not found …”

The fact is, the Delphi Project doesn’t contain the path to every needed files; it only contains path to the files in its folder. Path to “external” files is given by Final Builder (through a .ini file).
In the “Build Delphi” action windows, I can see that the Library Path is correctly set:
“%BIBLIO_ROOT_DIR%\Folder A;%BIBLIO_ROOT_DIR%\Folder B;$(BDS)\Folder C”, etc. BIBLIO_ROOT_DIR is correctly set too. “Use global Delphi Library Path” is uncheck. But compilation fails as said.

I’ve found a “workaround”: i put the Library Path which is in the .ini file into the delphi search path, and then check the box “always use search path from project settings File” in FinalBuilder. However, I don’t want to do that for every project. The paths are all in the .ini file, they’re all correctly loaded into Final Builder, in my mind the compilation should work.

What am i missing?

We need more information to be able to help you here.

What exact version of FinalBuilder 8 are you using?
What delphi version are you using?
What delphi version did you select on the Delphi Action?

I’m using Final Builder v8.0.0.2228 and Delphi 10.2 Tokyo.
I’ve selected Delphi 10.2 Tokyo on the Build Delphi action.
However, the “General” tab of this action says: “The action supports compiling Delphi 3 to XE8”, so I’ve also tried to select Delphie XE8.

But the Delphi version shouldn’t be a problem here: as far as i know, it’s working on another computer with this Delphi version and FinalBuilder 8 (yet I don’t know the exact version). Sadly I don’t have access to this computer to see the differences, I only know that people back here told us to use Delphi 10 and FB8.

The version you are using was released well before Delphi 10.2, it is missing functionality you need.

I’m guessing you are using as there never was a .228 (apart from a beta version). It’s likely the other version is newer and has 10.2 support.

The simple answer is you need to update the version of FinalBuilder you are using.

OK. I’ll try with it asap and let you know. Hope it works :slight_smile:

So, i finally could get the new version (took long enough).

The problem is not solved at all.

Now i have FB v8.0.0.2701, the “build delphi” action says that it supports Delphi 3 to 10.3, i’m using Delphi 10.2 Tokyo, the Library path is still correctly set in FB while the Search Path is taken from the Delphi project file.

But the “Build Delphi” action still fails with error message “Unit … not found” for each unit located in the Library Path.

What is going wrong here?

EDIT: I think that maybe my BIBLIO_ROOT_DIR variable is wrongly edited somewhere; will investigate that. Still open for any idea.

On the delphi action, check that the framework dropdown is set to the appropriate setting, as this sets the namespace prefixes. That would be my guess if everything else is correct.

Ok i found out.
There was a little “hidden” script in FB, which changed the value of my BIBLIO_ROOT_DIR “after action”. So the Library path was really wrong and the units couldn’t be found.

Thanks for the help.