Password change in Automise Map Network Drive action when project copied to new machine?

This is a weird one. As mentioned in another thread, we are moving our projects from an old VM (CT1) to a new VM (CT2). We have copied over our project files, and some of them are running fine on CT2 without any changes.

There is an action that maps a network drive from another box (call it CDB), using a particular login and password. We copied the project from CT1 to CT2, and on CT2 I get an error of “Access Denied” when the Map Network Drive action runs. I have not changed the login or the password, and IT tells me that the login should have the same access to map a drive from CT2 as from CT1.

Is there any chance that copying over the project file changed the password in some way? Could there be a difference in the password based on the fact that the Automise versions are slightly different?

CT2 (new machine) is running Automise, while CT1 (old machine) is running

Any guidance that does not mean that we have to reset the password for the network user would be much appreciated.



Moving the project to a new machine should not make any difference, nor will the versions.

The map network drive action calls “net use” - so the best option would be to test this outside of Automise and see if it works.

Weirdly enough, the difference was that the new machine (or possibly the new version of Automise) required the domain name in front of the user ID. Once I added that, it worked.

Net use has always required the domain name

[devicename | *] [\\computername\sharename[\volume] [password | *]]
        [/USER:[dotted domain name\]username]
        [/USER:[username@dotted domain name]

I checked and the code for that action hasn’t had any changes since 2013!

:grinning: All I can tell you is that for the last several years we have used a username without a domain name in that field, and it worked until we moved to the new machine.