How to get Eurekalog to run as post processor

I’ having trouble getting Eurekalog to run post compilation. The previous action compiled the project as a 64 bit dll.

I have added an action (Execute Program)

  • executable path $Agent.EurekaLog.Path$\bin\ecc32.exe
  • working directory $Workspace$\Output
  • Arguments --el_alter_exe=%RepositoryPath%%FHIRServerProjectFile% $Workspace$\Output*.dll

The log shows
Working Directory: E:\CI_AWS\Ws\2541\Output
Executable: C:\Program Files (x86)\Neos Eureka S.r.l\EurekaLog 7\bin\ecc32.exe
Arguments: --el_alter_exe=E:\CI_AWS\Ws\2541\Source\HealthOne_2021\FHIR\FHIREngine\FHIRServer.dproj E:\CI_AWS\Ws\2541\Output*.dll

The output shows an error

Loading EurekaLog options…
Compiled file “E:\CI_AWS\Ws\2541\Source\HealthOne_2021\FHIR\FHIREngine.\Win32\Release\FHIRServer.dll” not found

I also tried passing the *.dproj as the parameter but get the same error

What settings need to be changed ?

I think for 64 bit you need to tell eurekalog which compiler to use with --el_compiler

Thx, I’ll take another look

And while you’re online, what framework do you use for the Continua web UI.
Stay safe - we’re back into a snap lockdown over the ditch:(

Continua is built with mvc and jquery. That might change in the future but for now we’re focused on features rather than rewriting the front end (something we do want to do, but it’s a huge task).

We’re in our second week of lockdown here in Canberra (first time since last year) - we all work from home (since last March) so it’s not too bad so far.

1 Like