FTPS and SFTP trying to make directories?

We upgraded to lastest release version and now on FTPS and SFTP we are getting errors that directories already exist. It’s like FB is trying to make each directory (even if it exists on ftp) when it’s batch uploading an entire directory.

You haven’t really give us much to go on. Which version did you update from? We would need a lot more information to be able to figure out what is going, which actions you are using, log output etc. Also, which SFTP abd FTPS server software are you connecting to? Ideally if you can send your project file to support @ finalbuilder.com we can take a look and see if we can replicate the behavor here.

Sorry I left out details because I was assuming others were seeing it.

On It worked with previous versions. These scripts are years old. I skipped a few builds in there. I might uninstall and go back a few months.

FTPS upload gives “FTPS Upload Files action failed. 550 Directory already exists”

It’s a FileSet which is folders and files. And then an upload of that FileSet.

I’m told it’s Filzilla Server, but haven’t confirmed.

I’d have to see if we can sanitize the project file enough to send and still have it make sense for debugging.

I have managed to reproduce the problem here, it looks like the newer version of the library we are using has changed the exception type and we are now looking at the wrong property for the error codes. Working on a fix now.

Please try this build : http://downloads.finalbuilder.com/downloads/finalbuilder/800/FB800_2453.exe

Note this build only has changes/fixes for FTPS, I wasn’t able to reproduce the error for SFTP.

Sorry for the delay in testing this. Looks good. No issues on this build.

The build you linked to fixed the bug. It looks like the bug is present in Did this fix not get merged back into production?

The fix is definitely in the production build, so my guess is this will be a slightly different issue. Please send your logs to support - although we probably won’t get to look at it till the new year.

The FTPS server for this customer is running Filezilla Server.

I went back to 2453 and everything is good again.

From the logs:
Aquiring connection object…
Building directory tree
Creating remote directories…
FTPS Upload Files action failed. Directory value cannot be empty.

Ok, this looks like a slightly different issue. There were further changes to the FTPS actions since build 2453 to improve the performance and fix other issues we found in testing. I will look into this in the new year. In the mean time, if you can send your full log output to support I can try to figure out exactly what is happening.

I just upgraded to 2590 and this bug is still around. Back to 2453 I guess.

The logs always look something like this.

RECEIVE: 250 CWD successful. “/” is current directory.
Creating remote directory : /data
SEND: MKD data
RECEIVE: 550 Directory already exists
RECEIVE: 250 CWD successful. “/” is current directory.
Creating remote directory : /Styles
SEND: MKD Styles
RECEIVE: 550 Directory already exists
FTPS Upload Files action failed. Directory value cannot be empty.

Please send the full log for the Fileset and the FTPS actions to support @ finalbuilder.com so we can try to reproduce the exact conditions here.

We did take an update to the SSH/SFTP/FTPS libraries recently so it is worth trying this build (which is the same as the most recent release otherwise) which has that update applied.

All of my SSH/SFTP/SSH tests (against bitvise and filezilla) worked fine so I need a new test that will reproduce this.

Can you also confirm which FTPS Server (and version) you are using? Different servers exhibit different behaviors (despite the spec) - client libraries typically have a bunch of workarounds for specific servers/versions to deal with non standard behavior - it’s possible the vendor hasn’t encountered a behavior.

2593 has same issue. I’ll have to sort out some way to scrub data in order to send you logs. The script is nothing crazy.

FTPS Connect, FileSet define, FTPS Upload the set, FTPS disconnect.

FTPS server is FileZilla. But we have ran scripts against large hosting companies FTPS running I don’t know what and same results. SFTP and FTP are fine. Just FTPS.

Logs sent. I ran it once with 2453 (worked) and then 2593 (failed). So the logs should have both.