Freshly installed Continua CI can'T run simple configuration

I created a completly Continua CI installation on a new server.
then I cloned a repo .
After that i create a very simple configuration which just contains a “if true”

When i run the confuguration i get the following error.
What am I doing wrong`?

Unexpected error reported from server: could not insert: [Continua.Modules.Builds.BuildRepository#73ddf380-a910-4f90-85e1-ac8600fcac9a][SQL: INSERT INTO builds_buildrepository (CacheRevision, Branch, Branchdisplayname, Tagname, Revision, RepositoryId, BuildId, CommitsSinceLatestBranchTag, LatestBranchTagId, id) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?)]

one addition. in the log I found “Message: 42703: Spalte »branch« von Relation »builds_buildrepository« existiert nicht”

How the the branch column be missing in a new datgabase?

When I loog with pgAdmin IO can see the brand is there but in uppercase


Any known issues?

Manually renaming the column to lowercase solves it

Hi @gentlehag,

Thank you for reporting this (and for figuring out the cause). This bug appears to have been introduced in v1.9.2.484 when we upgraded the FluentMigration component which runs our database migration code. It was changed from being case-agnostic (automatically lowercasing column names) to case-insensitive. We will get an update out later today to address this issue.

This issue has now been fixed in version

thx for my it also worked to manually rename the column from upper to lowercase ? does the fix provide more hep and fixes or not required to apply if i renamed it manually?

Hi @gentlehag,

The fix renames the column if it has the wrong case. You therefore do not need to apply it for this particular issue as you have already done that manually. It does, however, contain fixes for other issues as detailed in the link above.