Fatal: F1026 File not found

While using Final Builder to compile a Delphi XE5 Solution I get a ‘Fatal: F1026 File not found’ error. The solution builds fine without errors, hints, or warnings inside of the EDI. I have checked and verified the file it is looking for does exist. Any ideas on what the problem could be?

Just an update here on what I have found so far… The application is being built with the dcc32.exe compiler. The file that it is unable to find is forms.dcu. RAD Studio XE5 can compile and run this application just fine it is this compiler having the issue. I tried adding the directory location for vcl.forms.pas to the library path but when I do that RAD Studio comes back with 394 Warnings and 67 errors all related to missing objects which I assume Don’t ship with my version of RAD Studio XE5. I would think that Final Builder should be able to use the forms.dcu file from the IDE or I should be able to default the search location to the correct folder but I have not succeeded at this yet.

On the Directories tab of the action, make sure the Framework (bottom right) is set to VCL. Newer versions of delphi use namespaces for everything, so forms is actually Vcl.Forms, and the framework selection fills in the default namespace prefixes which enable the compiler to find Vcl.Forms when only forms is specified.

1 Like

Oh, and you can usually solve this problem by loading the settings from the delphi project file, however for some projects (dproj) that were upgraded from older versions of delphi this does not work, due to bugs in the delphi IDE.

I am loading everything from the Delphi Project File. I had to do that to handle several 3rd party components that are used in the solution. The Solution contains 71 different projects that were all upgraded from Delphi 2006. This is not the only one to use VCL forms but the only one getting the error. I may try reconverting the project but based on your comment not sure if that will help.

okay. I recreated the entire project from scratch using a new VCL form Template in RAD Studio XE5 and copying the code itself over. When I was complete I got a successful build from FB. It would seem that there was a conversion error. trying to redo the conversion did not seem to help but recreating from scratch did. Thank you everyone for the help here.

I am new to FrameBuilder as of today and was stuck on this very point. Thanks Vincent for the helpful answer. It worked!