Email/SSL/TLS issues - not sure if it is a bug or not

Trying to send an email through Office365 SMTP ( When I use port 25 without SSL or TLS, I get an error that STARTTLS is required to send mail, and the email fails. When I try the same port with Implicit TLS (which requires SSL, as I cannot specify a TLS choice without the SSL box being checked), I get a different error:
Error connecting with SSL.
error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

If I try to connect with TLS and SSL and authentication on port 587, I get a Connection Refused error.

I am using I could install if you think that this issue has been solved in that version. I searched the forums for SSL/TLS related questions, and did not see any indication of issues that have been solved lately.

Thanks for any help.

– Jonathan

Hi Jonathon

I don’t have access to office 365 to test this at the moment, however I do have some test projects on my pc from back when we did, and they use

Use Explicit TLS
Port 587

As for the difference between builds 1341 and 1177 - the only change that I can see that might affect this is “Send Email Action - Removed insecure SSL versions.” which happened a few weeks after 1177 was released - this commit removed support for SSL3 and I suspect this may be the cause of the issue you are seeing.

So it’s defintely worth updating to the latest build.

I have installed 1341, and set the SMTP settings as you showed. I am now back to getting a “Connection refused” error. The issue was not fixed.

Any ideas? Is there any way to set the SMTP settings to use a different port with office365 successfully?

We were able to test it here using someone’s personal office 365 account and it worked using the settings I suggested.

Are you setting the values directly on the action or via the options dialog and using the global smtp options?

I suspect there may be a security setting on your office 365 account that needs a change

You were correct - we needed to get access to port 587 opened up. Now, though, the emails are being sent sometimes and the connection is being refused sometimes. The settings are the same all the way through. Any ideas?