Credentials for Mapping a Drive do not work unless I am logged in - and credentials are not mine

EDIT: Automise

We have a project that maps a network drive, reads files on that network drive, creates new files based on that data, and uses SFTP to send the files off. The credentials used are for a login called “webbackup”, which is a domain login that is used for MANY of our scheduled Automise processes.
When run using Windows Task Scheduler when I am not logged into the machine, the mapping of the network drive fails with an error message stating that the “webbackup” login is locked out and cannot be used.

But this is not the case - the login, as mentioned, is used for many of our processes, and I have checked many times with our IT folks and they see no evidence of the webbackup login being locked out at all, or even logging in incorrectly. If I run the process through Task Scheduler by kicking it off manually (using the Run option), the project works fine - maps the drive correctly and does the rest as well. The process in Task Scheduler runs under the webbackup ID as well.

Any ideas here? Is there something odd about mapping a drive that does not use credentials the same way when the ID that kicks off the process is different? I suppose that it is possible that when I run the task manually using Task Scheduler in Windows, the scheduled process runs as me even though it is not supposed to?

This has happened for muliple consecutive days…and I have no idea why, so I am coming to you.


Are you specifying the user/pwd in the map drive action? if so remove them so that it will use the scheduled task’s user.

The action itself calls net use so if that is failing then this would suggest an issue outside of Automise. You could test this by creating a simple batch file to map a drive and schedule that in the task scheduler.

Interesting…I am specifying the user/pwd in the map drive action. But the credentials for that are the same as the credentials for the scheduled task. Why would that not work? Also…if the credentials are specified for the map drive action, why would it care how the Scheduled Task is kicked off?

But I will try removing the Map Drive action credentials and see if it fixes the issue.

I removed the credentials from the Map Drive action…and there were no errors reported with the project this morning. Still not sure WHY, but the issue seems to be fixed. Thank you!

1 Like