Connection to SFTP server has been lost

We have setup an SFTP connection to an external server in Automise V4 - (current build).  For some reason, we are loosing connection for no apparent reason to the server.  So with just an SFTP connect and an SFTP disconnect command, the server connects, then on the disconnect (or an upload file on the next step), the SFTP is failing with and SFTP error - this is not happening universally with other SFTP clients.  

In Automise V3, the connection works fine.  In fact, we upgaded a V3 to V4.  In V3 is work and V4 it does not. Since we had other SFTP's that work fine, I was thinking it might be the remote server, however the fact that it works in V3 and not V4 seems strange to me.  Not sure if this is a known bug or what...

The SFTP library was upgraded between V3 and V4. What is the actual error you are seeing? What is the SFTP Server software/version?

I know this is an old thread, but we are running into this as well, pretty consistently. Was there ever a fix implemented for this?

The error message we keep getting is:

“SFTP Error Message: Connection to the SFTP server has been lost and cannot be re-established. Failed to connect to remote server. Connection failed (error code is 10060)”

Hi Jonathan,

If you could send us a sample project to support that will help us greatly in diagnosing this issue. The project doesn’t need to contain any server identifying information, just the connection settings (i.e. please remove username, password, server address).

If you could also include all the connection log information from a failed and success attempt, again with any server identification removed.

Lastly, and most importantly knowing the SFTP server software your connecting to and its version would be of great help. Typically this is reported by the server when connecting to it. The majority of these issues tend to be a server and client incompatibility, or configuration issue.

Please feel free to send all these details to our support email address ( and reference this forum case.

I have sent off an email this morning. I think I included all that you are asking for, but please let me know if you need more.

I tried to implement your solution, but I ran into a snag. I responded to your email. This is just a bump of the thread.

Just a note that this was answered through email. Let us know if there are any further issues.