Bug with "Delete Scheduled Task" on windows 2016 server


(David Novo) #1

The follow task

image

fails with the following error on windows server 2016

image


(Vincent Parrett) #2

Are you running as admin? Working with schedule tasks requires you run as admin (not just have admin privileges).


(Vincent Parrett) #3

I just tested it here on windows server 2016 and windows 10 and it worked first time.

I’m wondering if there is some installer option you need for schtasks.exe to be installed?


(Vincent Parrett) #4

Forgot to mention, it only worked when running Automise as admin, otherwise I get access denied (not the error you were seeing though).


(David Novo) #5

Hi Vincent,

I apologize, the task does not exist.

The actual bug is that even though “fail if the task doesn’t exist” is unchecked, the action still fails if the task does not exist.


(Vincent Parrett) #6

Thanks. schtasks.exe doesn’t give different exit codes for different errors, it just exits with 1, so we have to parse the output text… which seems to be different on different versions of windows. Not ideal but not uncommon with windows command line tools :confused:

This build has updated parsing to deal with the output on Server 2016 :

http://downloads.finalbuilder.com/downloads/automise/500/AT500_1036.exe
http://downloads.finalbuilder.com/downloads/automise/500/ATCMD500_1036.exe
http://downloads.finalbuilder.com/downloads/automise/500/AutomiseRunner500_1036.exe


(David Novo) #7

Thank you so much for the prompt fix.