Automise process starts and hangs and there is no log I can find

We have a batch overnight process that stopped working correctly about 5 days ago. I thought it was because a set of credentials had expired and needed to be reset, but even after that was taken care of, the batch process kept hanging for hours on startup.

I understand that there are issues that happen from time to time…the problem is that I do not know how to access a log that may tell me WHY this is happening. I do not see anything in the Automise log for the process when I try to look at it in Automise. It just hangs before actually doing anything.

When I run the process manually (not through the scheduler), it runs fine, but when I try to schedule it, it just hangs. Is there a log I can look at anywhere? Is there a way I can make it export a log that I cannot see right now? All I have to go on is that the project starts and nothing happens. Not even the first basic steps (where variables are set) seem to be getting run.

I keep having to start our nightly batch manually after cancelling the ATCMD.exe job that is running the scheduled batch. Any help would greatly be appreciated.



Hi Jonathan

Automise does create a log file, usually right next to the project file, with the file extension .log5

Open the project file in the Automise IDE (after a hang), and you should be able to see if the project actually started running and where it got up to by going to the Run History view. If you don’t see an entry for the schedueld run, then the project did not actually start running (ie Automise hung during startup). If you do see the entry, double click on it and that will take you to the log view so you can see where it got to.

The other thing that might have happened is a crash, although usually in that case it would write a bugreport file and exit. Login as the same user as the schedule runs Automise as, then open explorer and go to %TEMP% - there may be a file named ‘Automise Bugreport.txt’

You could also take a look at the windows eventlog to see if anything relevant stands out.

The most common reason for hanging is running an external tool which is then prompting for input, or displaying a message box or some other ui. It could also be waiting for a resource, for example a file share etc.

Lastly, and I know this sounds cliche, but try rebooting the machine. I say this because I have seen issues after windows update has run and the machine is awaiting a reboot… programs would not run but after rebooting it resolved itself.

Thank you for the response! I was going to mention - other batch processes that Automise is running on the same machine are working fine - only this one is not. I am familiar with the Run History and Log views…but they are telling me nothing. It seems like it is hanging on the first step…but the first few steps are only supposed to be setting variables. The app does not crash - it is still running according to Task Manager on the machine, and in order to view the project in the Automise IDE I have to end the process in Task Manager - otherwise I cannot view the project because it is running.

Rebooting the machine is a possibility…though because other batch processes are running fine I am not optimistic that it will solve the problem.

To recap: When the task is scheduled, it hangs. I end the process, and go into Run History and then into Log View…where no steps are marked as completed and there is no end date for the first step. I will try the reboot, and check tonight to see if the process runs.

When I run the project manually as myself, it runs fine. The user that runs all of the scheduled batch processes has no problem with the numerous other Automise processes that are run during the day, but this one started failing 6 days ago. Any help/guidance is appreciated.

Are you able to send us your project file (to support @ ) - that way we can see if we can reproduce it.

Actually…though I never would have believed it…the reboot of the machine seems to have worked. Well done. We can move this out of the Bugs forum if you like.

1 Like

I’ve lost count how many times weird inexpiable things on windows have been resolved by rebooting!