All Builds fail with Continua CI -


all our builds are failing. There is something broken with the repository rules. A symbol ‘1’ is inserted before the configured output path.

[Fatal] The working directory “C:\Continua\CI_WS\Ws\20908\1MyApp\Buildsys” does not exist.

I tried to download “Continua CI - Released”. However, that version seems to be removed of your server.

This is a showstopper!!!


The links should be working now.

Can you provide some more information on where this error is happening and your repository rules?

The log:

12:55:12 Stage: Build
12:55:13 Server To Agent Workspace Sync
12:55:13 Started syncing files from the server ‘localhost’ to the agent ‘myagentpc’
12:55:16 Finished syncing files from the server ‘localhost’ to the agent ‘myagentpc’.
12:55:16 MyApp
12:55:16 [Fatal] The working directory “C:\Continua\CI_WS\Ws\20908\1MyApp\Buildsys” does not exist.

That’s it.

Repository Rules:
$Source.MyRepo$\SomeDir** >> MyApp
$Source.MyRepo$\AnotherDir** > MyApp

What’s the first stage action and the working directory of that action?

Calling the finalbuilder action.

The call is

Also note:

I’ve just checked what gets copied by skipping the cleanup procedure. The installation is fine!!! There is no ‘1’ symbol in the path.

I have installed the latest version The bug is present in this version too.

Are you sure that it is:

That does not appear to be a valid expression? It should be something like $Source.MyRepo$\SomeDir\MyProject.fbp8

Also, if you you enable the “log repository rules” option then the files copied should be listed in the log.

This is the setting for finalbuilder-action/projectfile.

There was no change to the configuration on our side.

I installed the latest CI version this morning. Before that the builds were running fine.

I can reproduce the error, but the path you are using is invalid. The correct way to refer to the workspace is $Workspace$. I am surprised that $Source$ ever worked. Which version did you upgrade from?

I think we updated from v1.9.0.451. So this was an update to 1.9.1.x

Are you able to replace $Source$ with $Workspace$ in your configurations? Do you have a lot?

The builds run now after i changed to $Workspace$\MyApp

I’ve changed several configurations of mine. We can handle this in-house.

If $Source$ should not have worked, what is the recommended configuration?


$Source.MyRepo$ refers to the folder that the source files are copied to. In your case: C:\Continua\CI_WS\Ws\20908\MyApp. This only works if repository rules for MyRepo copy the files to a single folder.

$Workspace$ refers to the root workspace folder. In your case:
C:\Continua\CI_WS\Ws\20908. This can be used more generally for files outside of the repository paths.

I will look into changing the error message to state that $Source$ is invalid if used as such in an expression.

Hi Dave,

thanks a lot for your help!!! I know it’s kind of late in Australia now. I appreciate!!!

We will change our settings to use $Source.Repo$.


1 Like