XMPP Publisher seems to not work anymore

I’m using your xmpp publisher in our company. In the current version of continua ( the publisher is not able to authenticate. I’m not sure in which version it happens the first time. Below i have configuration of my xmpp publisher. The first error happens when i try to save the configuration or validate it.

Type: XMPP
Subscription Types: Users and groups
Network Host: Empty
Resource Name: Continua CI XMPP Notification Service
Auto-start TLS: true
Allow untrusted certificates: true

Username, server, password and port are valid. I tested them with my own local xmpp client and it worked without problems.

Error message
Failed to send test message to the specified XMPP id: The following error occurred while publishing an XMPP notification: System.IO.IOException: Authentication failed because the remote party has closed the transport stream. at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult) at JabberNet.bedrock.net.AsyncSocket.StartTLS()

Hi Albrecht,

We haven’t made any changes to the XMPP publisher since the first 1.9 release in June last year. The error you are seeing implies that the publisher was able to connect to the server but then failed when starting a TLS session. I suspect that this issue maybe a result of change of TLS protocol support on the server. Have you tried connecting with Auto-start TLS set to false?

Can you provide some more details about your XMPP service so that we can attempt to reproduce this error?

  • What XMPP server software are you using? Does it support TLS?
  • What version of Windows (or other OS) is it running on? Which TLS protocols are enabled? In Windows, check the registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols (for more info: TLS registry settings)

Can you also let us know what settings you used with your local XMPP client (and what the client software is)?

Hi Albrecht,

Please try the latest version - just released. We have added support for the TLS 1.1 and 1.2 protocols to the XMPP publisher.

Hello Dave,

it seems we’ve found the problem. I applied your latest update (, which provides support for TLS 1.1 and 1.2. We used ejabbered and disabled TLS 1.0. Now it works because both support the same protocol.
Thanks for the update.

1 Like