# SSH Service fails to start after a Windows restart due to an cryptographic problem

**URL:** https://www.finalbuilder.com/forums/t/ssh-service-fails-to-start-after-a-windows-restart-due-to-an-cryptographic-problem/6102
**Category:** Bugs
**Created:** [February 15, 2018, 11:19am UTC](https://www.finalbuilder.com/forums/t/ssh-service-fails-to-start-after-a-windows-restart-due-to-an-cryptographic-problem/6102 "2018-02-15T11:19:48Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![kay.zumbusch](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/k/cc9497/32.png) [@kay.zumbusch](https://www.finalbuilder.com/forums/u/kay.zumbusch)
#### Post date: [February 15, 2018, 11:19am UTC](https://www.finalbuilder.com/forums/t/ssh-service-fails-to-start-after-a-windows-restart-due-to-an-cryptographic-problem/6102/1 "2018-02-15T11:19:48Z")

</div>

Hi guys,  
  
after I installed the latest Windows updates on our ContinuaCI server and restarted the server the Continua SSH service fails to start. According to the debug log the password to decrypt the private key in server\_kerpair.pem doesn’t work anymore which sounds rather strange. Another restart of the service or the complete server did not help. I attached the log file for SSH service. Although the SSH service is down Continua CI still seems to work as expected.  
  
Our environment:  
Windows Server 2012 R2 Standard English  
Patch Level 2018-02  
Continua CI 1.8.1.692  
  
Kind regards  
  
Kay Zumbusch[\_\_42077\_\_0\_\_SSHService20180215.zip](https://www.finalbuilder.com/forums/uploads/default/original/2X/2/22313fc94bbef6f9b01ca64588602b61dc205c4d.zip) (1.375 KB)

---

<div class="post-metadata">

### Author: ![Vincent](https://www.finalbuilder.com/forums/user_avatar/www.finalbuilder.com/vincent/32/938_2.png) [@Vincent](https://www.finalbuilder.com/forums/u/Vincent)
#### Post date: [February 15, 2018, 8:11am UTC](https://www.finalbuilder.com/forums/t/ssh-service-fails-to-start-after-a-windows-restart-due-to-an-cryptographic-problem/6102/2 "2018-02-15T08:11:49Z")

</div>

Hi Kay   
  
 We believe (but haven’t been able to prove) this is caused by windows update, as we saw the same thing here. The most recent version has some code in place to deal with this.   
  
 As a temporary fix (until you are able to update), delete the C:\ProgramData\VSoft\ContinuaCI\SSHD\server\_kerpair.pem file and then start the service (a new key pair will be generated).   
  
 Continua CI only uses the SSH Service when it cannot access the share by SMB, eg when and agent is outside the firewall or in the cloud.

---

<div class="post-metadata">

### Author: ![kay.zumbusch](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/k/cc9497/32.png) [@kay.zumbusch](https://www.finalbuilder.com/forums/u/kay.zumbusch)
#### Post date: [February 16, 2018, 2:10am UTC](https://www.finalbuilder.com/forums/t/ssh-service-fails-to-start-after-a-windows-restart-due-to-an-cryptographic-problem/6102/3 "2018-02-16T02:10:26Z")

</div>

Hi Vincent,   
  
 thanks a lot. That worked as expected.   
  
 Kind regards   
  
 Kay Zumbusch
