# Service Logon Privileges error needs to be wrapped; why is it failing anyway? The user already has SeServiceLogonRight

**URL:** https://www.finalbuilder.com/forums/t/service-logon-privileges-error-needs-to-be-wrapped-why-is-it-failing-anyway-the-user-already-has-seservicelogonright/5702
**Category:** Discussion
**Created:** [May 30, 2016, 5:27am UTC](https://www.finalbuilder.com/forums/t/service-logon-privileges-error-needs-to-be-wrapped-why-is-it-failing-anyway-the-user-already-has-seservicelogonright/5702 "2016-05-30T05:27:37Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![jeroenp](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/j/c89c15/32.png) [@jeroenp](https://www.finalbuilder.com/forums/u/jeroenp)
#### Post date: [May 30, 2016, 5:27am UTC](https://www.finalbuilder.com/forums/t/service-logon-privileges-error-needs-to-be-wrapped-why-is-it-failing-anyway-the-user-already-has-seservicelogonright/5702/1 "2016-05-30T05:27:37Z")

</div>

See screenshot:  
  
  
  
At first I thought the user was missing the&nbsp;SeServiceLogonRight but that’s not it:  
  
C:\Windows\System32\>accesschk.exe /accepteula -q -a SeServiceLogonRight  
&nbsp; &nbsp; &nbsp; &nbsp; IIS APPPOOL\Classic .NET AppPool  
&nbsp; &nbsp; &nbsp; &nbsp; NT SERVICE\ALL SERVICES  
&nbsp; &nbsp; &nbsp; &nbsp; VCS-CI\ContinuaCI  
  
This setup used to work in the past, see the screenshots I’ve made back then:&nbsp;[https://github.com/jpluimers/Confer…puter-name](https://github.com/jpluimers/Conferences/blob/master/2014/2014-Continua-CI-installation/Stage-C-Continua-CI-Installing-Server.md#step-c03-the-user-requires-a-domain-or-computer-name)  
  
–jeroen

---

<div class="post-metadata">

### Author: ![Vincent](https://www.finalbuilder.com/forums/user_avatar/www.finalbuilder.com/vincent/32/938_2.png) [@Vincent](https://www.finalbuilder.com/forums/u/Vincent)
#### Post date: [May 31, 2016, 1:29am UTC](https://www.finalbuilder.com/forums/t/service-logon-privileges-error-needs-to-be-wrapped-why-is-it-failing-anyway-the-user-already-has-seservicelogonright/5702/2 "2016-05-31T01:29:42Z")

</div>

Can’t see the screenshot, dropbox reporting 404.

---

<div class="post-metadata">

### Author: ![jeroenp](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/j/c89c15/32.png) [@jeroenp](https://www.finalbuilder.com/forums/u/jeroenp)
#### Post date: [May 31, 2016, 6:20am UTC](https://www.finalbuilder.com/forums/t/service-logon-privileges-error-needs-to-be-wrapped-why-is-it-failing-anyway-the-user-already-has-seservicelogonright/5702/3 "2016-05-31T06:20:27Z")

</div>

Somehow it got invalidated. It’s now here:   
  
  ![]()

---

<div class="post-metadata">

### Author: ![jeroenp](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/j/c89c15/32.png) [@jeroenp](https://www.finalbuilder.com/forums/u/jeroenp)
#### Post date: [May 31, 2016, 6:30am UTC](https://www.finalbuilder.com/forums/t/service-logon-privileges-error-needs-to-be-wrapped-why-is-it-failing-anyway-the-user-already-has-seservicelogonright/5702/4 "2016-05-31T06:30:25Z")

</div>

> The forum plays URL magic on me; download the screenshot here: https://www.dropbox.com/s/aptj3olqjqo64yy/Screenshot%202016-05-30%2017.05.30.png?dl=0

---

<div class="post-metadata">

### Author: ![Vincent](https://www.finalbuilder.com/forums/user_avatar/www.finalbuilder.com/vincent/32/938_2.png) [@Vincent](https://www.finalbuilder.com/forums/u/Vincent)
#### Post date: [May 31, 2016, 6:36am UTC](https://www.finalbuilder.com/forums/t/service-logon-privileges-error-needs-to-be-wrapped-why-is-it-failing-anyway-the-user-already-has-seservicelogonright/5702/5 "2016-05-31T06:36:34Z")

</div>

If you use the machine name does that work? Nothing has changed in the installer so not sure what would cause that to stop working.

---

<div class="post-metadata">

### Author: ![jeroenp](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/j/c89c15/32.png) [@jeroenp](https://www.finalbuilder.com/forums/u/jeroenp)
#### Post date: [June 6, 2016, 1:16am UTC](https://www.finalbuilder.com/forums/t/service-logon-privileges-error-needs-to-be-wrapped-why-is-it-failing-anyway-the-user-already-has-seservicelogonright/5702/6 "2016-06-06T01:16:21Z")

</div>

Yes, that works, but it’s not nice.  
  
Could this be Windows 7 versus Windows 8?  
Do you have spare VMs to try on?  
  
–jeroen

---

<div class="post-metadata">

### Author: ![Sparky](https://www.finalbuilder.com/forums/user_avatar/www.finalbuilder.com/sparky/32/10_2.png) [@Sparky](https://www.finalbuilder.com/forums/u/Sparky)
#### Post date: [June 7, 2016, 2:46am UTC](https://www.finalbuilder.com/forums/t/service-logon-privileges-error-needs-to-be-wrapped-why-is-it-failing-anyway-the-user-already-has-seservicelogonright/5702/7 "2016-06-07T02:46:23Z")

</div>

Hi Jeroen,  
  
Using “./username” doesn’t work in our tests on Windows 7, Windows Server 2012 or Windows 10. &nbsp;We’ve not changed this code so we’re not sure how that would have worked in the past. We will however update the installer to deal with this account format.

---

<div class="post-metadata">

### Author: ![jeroenp](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/j/c89c15/32.png) [@jeroenp](https://www.finalbuilder.com/forums/u/jeroenp)
#### Post date: [June 9, 2016, 12:25pm UTC](https://www.finalbuilder.com/forums/t/service-logon-privileges-error-needs-to-be-wrapped-why-is-it-failing-anyway-the-user-already-has-seservicelogonright/5702/8 "2016-06-09T12:25:49Z")

</div>

I’m not sure which version I installed first, but it has worked one day.  
  
So thanks for fixing this in a future version of the installer.  
  
–jeroen
