# IIS problems

**URL:** https://www.finalbuilder.com/forums/t/iis-problems/2824
**Category:** Bugs
**Created:** [May 2, 2007, 3:25am UTC](https://www.finalbuilder.com/forums/t/iis-problems/2824 "2007-05-02T03:25:36Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![kgemeinhart](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/k/c4cdca/32.png) [@kgemeinhart](https://www.finalbuilder.com/forums/u/kgemeinhart)
#### Post date: [May 2, 2007, 3:25am UTC](https://www.finalbuilder.com/forums/t/iis-problems/2824/1 "2007-05-02T03:25:36Z")

</div>

Greetings,  
  
I’m having some problems when I try to execute the “Create Virtual Directory” action. If I click the Connect and update button on the Website tab, I get the following error message:  
&nbsp;&nbsp;&nbsp; "_Could not open IIS6 service provider on localhost: Invalid namespace._"  
  
There is also the following error in the windows event logs:   
"_DCOM was unable to communicate with the computer WORKGROUP using any of the configured protocols._  
  
_For more information, see Help and Support Center at [http://go.microsoft.com/fwlink/events.asp](http://go.microsoft.com/fwlink/events.asp)._"  
  
The same errors occur when I click the Update list button on the New Virtual Directory tab.  
  
This is using Final Builder 4.0.0.65 on Windows XP SP2. I’ve tried FB5 and Automise with the same results. I’m trying to access the IIS instance on my local system.  
  
Any ideas?  
  
Thanks,  
-Keith

---

<div class="post-metadata">

### Author: ![angus](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/a/b3f665/32.png) [@angus](https://www.finalbuilder.com/forums/u/angus)
#### Post date: [May 3, 2007, 1:08am UTC](https://www.finalbuilder.com/forums/t/iis-problems/2824/2 "2007-05-03T01:08:36Z")

</div>

Hi Keith,  
  
I’m assuming you do have IIS installed. Which version of the IIS actions are you using?  
  
If you’re using XP SP2 32-bit version, you’ll have IIS 5 and you need to use the IIS 5 actions.  
  
If you’re using XP x64 edition, you’ll have IIS 6 and you can use either the IIS 5 or IIS 6 actions.  
  
Regards,  
  
Angus

---

<div class="post-metadata">

### Author: ![kgemeinhart](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/k/c4cdca/32.png) [@kgemeinhart](https://www.finalbuilder.com/forums/u/kgemeinhart)
#### Post date: [May 4, 2007, 4:54am UTC](https://www.finalbuilder.com/forums/t/iis-problems/2824/3 "2007-05-04T04:54:44Z")

</div>

Thanks for the reply, Angus.  
  
I was incorrectly using the “IIS 6” actions. I tried the “IIS 5” actions, but those didn’t work correctly either. Finally, I tried the generic “IIS Actions” group, and those worked correctly.  
  
-Keith
