# Continua and Remote hg repository / Kiln

**URL:** https://www.finalbuilder.com/forums/t/continua-and-remote-hg-repository-kiln/4938
**Category:** Discussion
**Created:** [April 8, 2013, 10:03am UTC](https://www.finalbuilder.com/forums/t/continua-and-remote-hg-repository-kiln/4938 "2013-04-08T10:03:44Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![haggy](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/h/edb3f5/32.png) [@haggy](https://www.finalbuilder.com/forums/u/haggy)
#### Post date: [April 8, 2013, 10:03am UTC](https://www.finalbuilder.com/forums/t/continua-and-remote-hg-repository-kiln/4938/1 "2013-04-08T10:03:44Z")

</div>

Hi

My target is to configure repositories which are automatically refreshed and are automatically starting builds.

My Idea was to point the repository to the online path to achieve this

In the Contiua Repository Dialog I want to link a remote repository but when I fill the repsotiroy path with the remote path i get on validation the error following error

The remote repository is a kiln repository, I created a access token and set it as user name also i set a dummy passwort. like descriped here

[http://kiln.stackexchange.com/quest...continuous](http://kiln.stackexchange.com/questions/4054/what-are-access-tokens-do-they-let-me-avoid-using-up-a-license-on-my-continuous)

I'm not sure wether i should point to a local clone of this repository. I tried it but it doesn'T automatically check for online changes.

So how do I solve this scenario?

---

<div class="post-metadata">

### Author: ![haggy](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/h/edb3f5/32.png) [@haggy](https://www.finalbuilder.com/forums/u/haggy)
#### Post date: [April 8, 2013, 11:10am UTC](https://www.finalbuilder.com/forums/t/continua-and-remote-hg-repository-kiln/4938/2 "2013-04-08T11:10:11Z")

</div>

here also my configuratio nscreen&nbsp;

Attachment unavailable

---

<div class="post-metadata">

### Author: ![Vincent](https://www.finalbuilder.com/forums/user_avatar/www.finalbuilder.com/vincent/32/938_2.png) [@Vincent](https://www.finalbuilder.com/forums/u/Vincent)
#### Post date: [April 8, 2013, 12:37pm UTC](https://www.finalbuilder.com/forums/t/continua-and-remote-hg-repository-kiln/4938/3 "2013-04-08T12:37:26Z")

</div>

Hi Haggy   
  
 The validation is supposed to ignore that, the not local error is actually expected (there is no easy way to validate a remote hg repo). Just click on “Save anyway” and it should work. I’ll take a look at the validation since I made changes to it last week.

---

<div class="post-metadata">

### Author: ![haggy](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/h/edb3f5/32.png) [@haggy](https://www.finalbuilder.com/forums/u/haggy)
#### Post date: [April 8, 2013, 1:12am UTC](https://www.finalbuilder.com/forums/t/continua-and-remote-hg-repository-kiln/4938/4 "2013-04-08T01:12:24Z")

</div>

Yeah works when i ignore the warning. Just thought I shouldn’t go on with this warning.- Perhaps a hint indicating that remote repositories can’t be checked (and this is ok ) would be nice

---

<div class="post-metadata">

### Author: ![Vincent](https://www.finalbuilder.com/forums/user_avatar/www.finalbuilder.com/vincent/32/938_2.png) [@Vincent](https://www.finalbuilder.com/forums/u/Vincent)
#### Post date: [April 9, 2013, 1:43am UTC](https://www.finalbuilder.com/forums/t/continua-and-remote-hg-repository-kiln/4938/5 "2013-04-09T01:43:38Z")

</div>

The validation wasn’t treating the http protocol as a remote repo, only https and ssh. This is fixed for the next beta.

---

<div class="post-metadata">

### Author: ![haggy](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/h/edb3f5/32.png) [@haggy](https://www.finalbuilder.com/forums/u/haggy)
#### Post date: [April 11, 2013, 9:51am UTC](https://www.finalbuilder.com/forums/t/continua-and-remote-hg-repository-kiln/4938/6 "2013-04-11T09:51:13Z")

</div>

Since the last beta this doesn't work any more at all :-(

Last Version the validation failed but the repo could get initialised.

Possibly the problem is that I can'T add a dummy pw for the access token ?

In the last version i was able to provide a dummy pw. perhaps thats the difference?

s. also.&nbsp;[http://kiln.stackexchange.com/quest...continuous](http://kiln.stackexchange.com/questions/4054/what-are-access-tokens-do-they-let-me-avoid-using-up-a-license-on-my-continuous)

---

<div class="post-metadata">

### Author: ![haggy](https://www.finalbuilder.com/forums/letter_avatar_proxy/v4/letter/h/edb3f5/32.png) [@haggy](https://www.finalbuilder.com/forums/u/haggy)
#### Post date: [April 11, 2013, 10:13am UTC](https://www.finalbuilder.com/forums/t/continua-and-remote-hg-repository-kiln/4938/7 "2013-04-11T10:13:49Z")

</div>

here the error message i forgot   
 Repository ‘[http://foo/repo](http://foo/repo)’ (a878fd8f-6cf0-466c-982d-1e71d29520ea) cannot be initialised: Running C:\Program Files\TortoiseHg\hg.exe failed with return code 255 and error output abort: http authorization required   
 (Args were : clone --noupdate [http://sc-vmdevsrv01/fogbugz/kiln/Code/3rdParty/InxMail/Dev](http://sc-vmdevsrv01/fogbugz/kiln/Code/3rdParty/InxMail/Dev) D:\fbci\Rc\a878fd8f --config ui.username=Continua)

---

<div class="post-metadata">

### Author: ![Vincent](https://www.finalbuilder.com/forums/user_avatar/www.finalbuilder.com/vincent/32/938_2.png) [@Vincent](https://www.finalbuilder.com/forums/u/Vincent)
#### Post date: [April 16, 2013, 3:37am UTC](https://www.finalbuilder.com/forums/t/continua-and-remote-hg-repository-kiln/4938/8 "2013-04-16T03:37:36Z")

</div>

Hi Haggy   
  
 Did you get past this error with the latest beta? I just tested with kiln again and it worked fine. If you are using access tokens, you must also put a dummy password in (kiln requires it). You can update the password field by clicking on the padlock symbol next to it to unlock the field.
