# Agents not Found after Update (Property collectors running)

**URL:** https://www.finalbuilder.com/forums/t/agents-not-found-after-update-property-collectors-running/6069
**Category:** Bugs
**Created:** [November 15, 2016, 1:41am UTC](https://www.finalbuilder.com/forums/t/agents-not-found-after-update-property-collectors-running/6069 "2016-11-15T01:41:45Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![gentlehag](https://www.finalbuilder.com/forums/user_avatar/www.finalbuilder.com/gentlehag/32/182_2.png) [@gentlehag](https://www.finalbuilder.com/forums/u/gentlehag)
#### Post date: [November 15, 2016, 1:41am UTC](https://www.finalbuilder.com/forums/t/agents-not-found-after-update-property-collectors-running/6069/1 "2016-11-15T01:41:45Z")

</div>

We upgraded continua ci to the most current version.  
  
From there on we can’t start any update. I can see that the agent is found and compatible but the builds itself are awating a &nbsp;client with seems to be blocked by the property collector  
  
\> No agents are currently available to execute the stage.&nbsp;  
**\> gp\_dev** : Initial agent property collection is not complete.  
  
but event after 45 minutes it is not working…  
  
in the log I see  
  
\> Agent Controller&nbsp;  
  
\> Error getting agent properties from a batch of 30 collectors for \<g class=“gr\_ gr\_208 gr-alert gr\_gramm gr\_run\_anim Grammar only-ins doubleReplace replaceWithoutSep” id=“208” data-gr-id=“208”\>agent\</g\>: ‘gp\_dev’ as a connection could not be established on gp\_dev:localhost. Make sure the port has been excluded from any firewall \> enabled on the target machine.&nbsp;\</span\>\<br style=“color: #000000;” /\>\> This event has been reported 376 times.  
  
any hint whats wrong. ? as the agent exists on the same machine i don’t believe the fire wall can make problems  
  
any advice?

![__37976__ 0__continua_1.png](https://www.finalbuilder.com/forums/uploads/default/original/2X/e/e5f47f734dbcadbb39b286f65b444dade85c83fb.png)

---

<div class="post-metadata">

### Author: ![Sparky](https://www.finalbuilder.com/forums/user_avatar/www.finalbuilder.com/sparky/32/10_2.png) [@Sparky](https://www.finalbuilder.com/forums/u/Sparky)
#### Post date: [November 16, 2016, 12:37pm UTC](https://www.finalbuilder.com/forums/t/agents-not-found-after-update-property-collectors-running/6069/2 "2016-11-16T12:37:33Z")

</div>

Hi Gentlehag,  
  
Check the Windows event log for error with ContinuaCIAgent as the source.&nbsp;  
  
I suspect that there is an error similar to “Error starting wcf service ‘AgentService’ : There is already a listener on IP endpoint 0.0.0.0:9002”. The agent uses Windows Communication Foundation (WCF) to communicate with the server. Sometimes this is not fully disconnected when the agent service is shutdown. The only solution we have at the moment is to restart the server.  
  
If restarting the server does not fix the issue, then please let us know which errors are in the event log. Also try enabling debug logging on the agent as the log will provide further details concerning what is happening on the agent.
